From: Vermaas, Josh (
Date: Wed Jun 08 2022 - 08:23:15 CDT

Hi Vaidehi,

What about if you run nvidia-smi from within WSL? Admittedly I don’t have much WSL experience, but at least up to 20.04, the driver stack you got alongside nvidia-cuda-toolkit was *ancient*, and may not have met the minimum specs for LibOptiX. In 22.04, I’d hope this has been improved, but maybe not!


From: <> on behalf of Vaidehi Doke <>
Date: Wednesday, June 8, 2022 at 9:07 AM
To: "" <>
Subject: vmd-l: Unable to useTachyon-Optix renderer when VMD is installed in Windows Subsystem for Linux (WSL)

Dear users,
I am trying to use VMD1.9.4a57 (April 27, 2022) in windows-11 laptop having Windows Subsystem for Linux (WSL) installed. In WSL I have installed Ubuntu 22.04 LTS and configured the VMD successfully.

While running VMD, I am getting error about OptiXRenderer as shown below:
I freshly installed Ubuntu 22.04LTS along with the latest NVIDIA driver and nvidia-cuda-toolkit. Still I am geeting error about "too old NVIDIA driver".

Furthermore, there is no option for Tachyon-Optix renderer in the rendering dropdown menu. (please see attached image below.)

It will be great help if you guide me to compile and use VMD in WSL such that I shall be able to generate high quality images using Tachyon-Optix (GPU-accelerated) renderer.

Details of GPU and GPU-driver in my system are as follows:

Vaidehi Doke